<!DOCTYPE html>
<html class="root root_js_disabled" lang="en-US" data-version="2.6.2.1" data-platform="desktop">
<head>
    <meta charset="utf-8" />
    <title>Take Back Idaho calls for Janice McGeachin to resign | krem.com</title>
    <script>!function(){window.performance.mark("tegna_server_response");var n=new URLSearchParams(window.location.search).get("otConsentString");if(n){document.cookie=`OptanonAlertBoxClosed=${(new Date).toISOString()}`;let e=new Date;e.setYear(e.getFullYear()+1),e=e.toISOString();var t=(new Date).toString().replace(/\ /g,"+").replace(/:/g,"%3A");document.cookie=`OptanonConsent=datestamp=${t}&version=6.0.0&interactionCount=0&isIABGlobal=false&landingPath=NotLandingPage&groups=${encodeURIComponent(n)}&hosts=&legInt=; expires=${e}`}}(),window.tegna=window.tegna||{},window.tegna.supportsJavascript="noModule"in document.createElement("script"),window.tegna.supportsJavascript?(document.documentElement.classList.remove("root_js_disabled"),window.tegna.performance={received:{time:window.performance.now()}},window.tegna.ie=!!window.MSInputMethodContext&&!!document.documentMode):document.documentElement.classList.add("root_ie_true");
//# sourceMappingURL=immediate.js.map</script>
    <style>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</style>
    <style>:root {
    --theme-primary: #045ea8;
    --theme-secondary: #045ea8;
}</style>

<link rel="preload" href="/modules.min_6.2.1.css" as="style" onload="this.onload=null;this.rel='stylesheet';window.tegna.performance.painted = { 'time': window.performance.now() };window.performance.mark('tegna_styled');" />
<noscript><link rel="stylesheet" href="/modules.min_6.2.1.css"></noscript>

<link rel="preload" href="/common.min_6.2.1.js" as="script" type="text/javascript" />

    <link rel="preconnect" href="//media.wbir.com">
    <link rel="preconnect" href="//interactive.wbir.com">
    <link rel="preconnect" href="//tgna-ux-dev.service.signalr.net">
    <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    <link rel="preconnect" href="//www.google.com">
    <link rel="preconnect" href="//adservice.google.com">
    <link rel="preconnect" href="//tpc.googlesyndication.com">
    <link rel="preconnect" href="//cdn.ampproject.org">
    <link rel="preconnect" href="//pagead2.googlesyndication.com">
    <link rel="preconnect" href="//www.gstatic.com">
    <link rel="icon" href="/assets/favicons/KREM.png?ver=2.6.2.1" />
    <link rel="canonical" href="https://www.ktvb.com/article/news/local/capitol-watch/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f" />
            <meta name="theme-color" content="#045ea8" />
            <link rel="amphtml" href="https://www.krem.com/amp/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f" />
        <meta itemprop="datePublished" content="1:25 PM PST February 26, 2022" />
        <meta itemprop="dateModified" content="6:16 PM PST February 26, 2022" />
        <meta itemprop="url" content="https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f" />
        <meta itemprop="magnet:custom" name="category" content="news" />
        <meta property="og:url" content="https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f">
        <meta property="og:title" content="Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign">
        <meta property="og:description" content="Take Back Idaho said it calls for McGeachin&#x27;s resignation after it learned McGeachin spoke at the America First Political Action Conference (AFPAC).">
        <meta property="og:type" content="article" />
        <meta property="og:image" content="https://media.krem.com/assets/KTVB/images/9996cdee-2ec3-4ab1-a7bd-a947fbe4ff91/9996cdee-2ec3-4ab1-a7bd-a947fbe4ff91_1140x641.jpg">
        <meta property="og:image:width" content="1140" />
        <meta property="og:image:height" content="641" />
        <meta property="og:article:published_time" content="1:25 PM PST February 26, 2022" />
        <meta property="article:opinion" content="false" />
        <meta property="article:content_tier" content="free">
        <meta property="article:section" content="krem,news,local" />
        <meta name="twitter:title" content="Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign">
        <meta name="twitter:image:src" content="https://media.krem.com/assets/KTVB/images/9996cdee-2ec3-4ab1-a7bd-a947fbe4ff91/9996cdee-2ec3-4ab1-a7bd-a947fbe4ff91_1140x641.jpg">
        <meta name="twitter:image" content="https://media.krem.com/assets/KTVB/images/9996cdee-2ec3-4ab1-a7bd-a947fbe4ff91/9996cdee-2ec3-4ab1-a7bd-a947fbe4ff91_1140x641.jpg">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="KREM2">
        <meta name="twitter:description" content="Take Back Idaho said it calls for McGeachin&#x27;s resignation after it learned McGeachin spoke at the America First Political Action Conference (AFPAC).">
        <meta name="twitter:domain" content="www.krem.com">


            <meta name="viewport" content="width=1170" />
            <meta name="site" content="krem.com" />
            <meta name="description" content="Take Back Idaho said it calls for McGeachin&#x27;s resignation after it learned McGeachin spoke at the America First Political Action Conference" />
            <meta property="fb:app_id" content="194226194463682" />
            <meta property="og:site_name" content="krem.com" />
            <meta property="og:locale" content="en_US" />
            <meta itemprop="pageType" content="article" />
            <meta itemprop="datePublished" content="1:25 PM PST February 26, 2022" />
    <script>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</script>
        <!-- OneTrust Cookies Consent Notice start -->
        <script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="bdf05041-f853-4b85-9e20-14bf7c2d88bc"></script>
        <script type="text/javascript">function OptanonWrapper() { }</script>
        <!-- OneTrust Cookies Consent Notice end -->
        <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004,C0002" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="true"></script>
<!-- utag_data -->
<script id="utag_data_script" data-visit-event-name="pageView" data-current-site-id="293" data-watson-keywords="Back Idaho,Idaho Lt. Gov. McGeachin,Take Back Idaho PAC,Take Back Idaho&#x27;s news release,America First Political Action Conference" data-page-type="article" data-gpt-network-code="32805352/wa-spokane-KREM-B3354_DesktopTablet" data-section="news" data-subsection="local" data-topic="" data-subtopic="" data-content-type="article" data-category="news" data-market="Spokane, WA" data-subcategory="local" data-keywords="KREM, Spokane, WA, news, local news, breaking news, traffic, weather, sports, events" data-document-title="Spokane&#x27;s Leading Local News: Weather, Traffic, Sports and more | Spokane, Washington | KREM.com" data-ga-property-id="UA-72904025-1" data-division="broadcast" data-site-type="desktop" data-page-url="https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f" data-canonical-url="https://www.ktvb.com/article/news/local/capitol-watch/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f" data-asset-id="8d5d1335-232b-4fcb-8353-c55c2983cf5f" data-article-keywords="local,news" data-content-title="Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign" data-content-categories="local,news" data-content-score="100" data-tracking-tags="" data-t1-publisher="zarmstrong@tegna.com" data-call-letters="KREM" data-article-byline="KTVB Staff" data-topics-included="false" data-video-included="true" data-video-autoplay="true" data-video-title="Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign" data-video-name="Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign" data-video-length="0" data-video-related-play="false" data-item-number="1" data-original-headline="Take Back Idaho calls for Lt. Gov. McGeachin to resign" data-cct-story="false" data-platform="desktop" data-full-environment="KREM" data-index-wrapper-url="//js-sec.indexww.com/ht/p/184603-146627631841778.js" data-a9-publisher-id="3276" data-a9-timeout="1000" data-pubmatic-desktop-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3953/pwt.js" data-pubmatic-mobile-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3954/pwt.js">!function(){var e;window.tegna.supportsJavascript&&(e=document.getElementById("utag_data_script").dataset,window.tegna.initialTracking={visit_event_name:e.visitEventName,current_site_id:e.currentSiteId,watson_keywords:e.watsonKeywords,template_type:"",page_type:e.pageType,division:e.division,site_type:e.siteType,page_url:e.pageUrl,gpt_network_code:e.gptNetworkCode,section:e.section,subsection:e.subsection,topic:e.topic,subtopic:e.subtopic,content_type:e.contentType,category:e.category,market:e.market,subcategory:e.subcategory,keywords:e.keywords,document_title:e.documentTitle,ga_property_id:e.gaPropertyId,canonical_url:e.canonicalUrl,video_included:e.videoIncluded,video_name:e.videoName,video_length:e.videoLength,video_related_play:e.videoRelatedPlay,article_date:e.articleDate,asset_id:e.assetId,article_keywords:e.articleKeywords,content_title:e.contentTitle,original_headline:e.originalHeadline,content_categories:e.contentCategories,tracking_tags:e.trackingTags,t1_publisher:e.t1Publisher,article_byline:e.articleByline,topics_included:e.topicsIncluded,call_letters:e.callLetters,item_number:e.itemNumber,content_score:e.contentScore,cct_story:e.cctStory,platform:e.platform,full_environment:e.fullEnvironment,index_wrapper_url:e.indexWrapperUrl,a9_publisher_id:e.a9PublisherId,a9_timeout:e.a9Timeout,pubmatic_desktop_url:e.pubmaticDesktopUrl,pubmatic_mobile_url:e.pubmaticMobileUrl},window.utag_data=JSON.parse(JSON.stringify(window.tegna.initialTracking)))}();
//# sourceMappingURL=utag-data.js.map</script>
        <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">var recaptchaCallback = function () {
                window.grecaptcha = grecaptcha;
                console.log('recaptcha is ready');
            }</script>
    <style>
        .root_ie_true template {
            display: none;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-header {
            position: relative;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-logo {
            background-image: url('/assets/shared-images/logos/krem.png') !important;
        }
    </style>
    <script type="text/javascript" data-taboola-type="article">window._taboola = window._taboola || [];
        let obj = {};
        obj[document.currentScript.dataset.taboolaType] = 'auto';
        _taboola.push(obj);</script>
    <!-- head content below this is dynamically added -->
</head>
<body>
    <script>if(window.tegna.supportsJavascript){window.tegna.addScript=e=>{var t=document.createElement("script");t.src=e,document.head.appendChild(t)},window.tegna.log=function(e,t,i,n){var o=(o=20-e.length)<0?0:o,a=(a=30-t.length)<0?0:a,r="log";"error"in console&&3===n?r="error":"warn"in console&&2===n?r="warn":"info"in console&&(r="info");a="["+e+"] "+" ".repeat(o)+t+" ".repeat(a);i?void 0:void 0},window.tegna.loadModule=function(e,i){var n=e.parentNode,o=n.querySelectorAll(".grid__template")[0];"undefined"!=typeof templatePolyfill&&templatePolyfill(n);var a=document.importNode(o.content,!0),t="IntersectionObserver"in window&&"IntersectionObserverEntry"in window;e.remove(),t?new window.IntersectionObserver(function(e,t){e.forEach(function(e){if(e.isIntersecting){o.remove(),n.append(a),n.closest(".grid__module").classList.add("grid__module_loaded_true"),n.closest(".grid__module").classList.remove("grid__module_loaded_false"),t.unobserve(n),"undefined"!=typeof require&&require([i]),"$"in window&&$(window).trigger("tegnaBroadcast",["grid","addedSection",{$el:$(n),el:n}]);let e={el:n};"$"in window&&(e.$el=$(n)),window.dispatchEvent(new CustomEvent("tegnaBroadcastNoJQ",{detail:{source:"grid",action:"addedSection",data:e}}))}})}).observe(n):(o.remove(),n.append(a))};class e extends HTMLElement{get os(){return this.getAttribute("os")}set os(e){this.setAttribute("os",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}connectedCallback(){var e=navigator.userAgent||navigator.vendor||window.opera;let t="unknown";/android/i.test(e)&&(t="android"),/iPad|iPhone|iPod/.test(e)&&!window.MSStream&&(t="ios"),t===this.os.toLowerCase()?this.active=!0:this.active=!1}}window.customElements.define("tegna-sniff",e);class t extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}}window.customElements.define("tegna-variant",t);class i extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}constructor(){super()}connectedCallback(){window.setTimeout(()=>{let t=[...this.children],a=t[0].uuid;var e=window.localStorage.getItem(this.uuid);null!==e?(a=e,window.tegna.log("_abtest","showingStoredVariant",{test:this.uuid,variant:e})):(a=t[e=t.length,Math.floor(Math.random()*Math.floor(e))].uuid,window.localStorage.setItem(this.uuid,a),window.localStorage.setItem(`${this.uuid}_tegna_expire`,Date.now()+108e5),window.tegna.log("_abtest","showingNewVariant",{test:this.uuid,variant:a}));const i=async(e,t,i)=>{var n=document.querySelector(".page").dataset.uxTrackingUrl;const o=await fetch(n,{method:"POST",headers:{"Content-Type":"application/json",pragma:"no-cache","cache-control":"no-cache"},body:JSON.stringify({testId:this.uuid,siteId:document.querySelector(".page").dataset.siteId,variantId:a,click:e?1:0,impression:t?1:0})});o.text().then(e=>{i(e)})};for(var n=0;n<t.length;n++)if(t[n].uuid===a){t[n].active=!0,[...t[n].querySelectorAll("a:not([data-ab-click-mode=ignore])")].forEach((t,e)=>{t.addEventListener("click",e=>{e.preventDefault(),e.stopPropagation(),i(!0,!1,()=>{window.location=t.getAttribute("href")}),window.setTimeout(()=>{window.location=t.getAttribute("href")},500)})});let e=new IntersectionObserver((e,t)=>{e.forEach(e=>{e.isIntersecting?(window.tegna.log("_abtest","attemptingImpression",{el:this,test:this.uuid,variant:a}),i(!1,!0,()=>{window.tegna.log("_abtest","impression",{el:this,test:this.uuid,variant:a})}),t.unobserve(e.target)):window.tegna.log("_abtest","notIntersecting")})});e.observe(this)}else t[n].active=!1})}}window.customElements.define("tegna-ab",i)}
//# sourceMappingURL=above-page-scripts.js.map</script>
    <div data-module="page" data-state="ready" class="page"
         data-embed="false"
         data-platform="desktop"
         data-page-type="article"
         data-ux-tracking-url="https://abtesting.tegnadigital.com/api/SendUxAbTestingData?code=84t6e3jO2Lzs3tFOiUcMV64Ma39HJNfb7QpjKbQiQXbt9nWEQbdv2w=="
         data-api-key=""
         data-environment="Production"
         data-is-monitor="false"
         data-is-preview="false"
         data-site-id="293"
         data-primarydomain="krem.com"
         data-environment-base-url="https://www.krem.com/"
         data-call-letters="KREM"
         data-full-environment="KREM"
         data-twitter-id="KREM2"
         data-fban="194226194463682"
         data-refresh="420"
         data-dfpid="32805352"
         data-comscoreid="19962895"
         data-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah"
         data-targeting-video_included="true"
         data-targeting-ttid="8d5d1335-232b-4fcb-8353-c55c2983cf5f"
         data-targeting-pgtype="article"
         data-targeting-topic_section=""
         data-targeting-url="https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f"
         data-is-video="false"
         data-is-longform="false"
         data-gptid="wa-spokane-KREM-B3354_DesktopTablet"
         data-tealium-url="//tags.tiqcdn.com/utag/tegna/krem-redesign-desktop/prod/utag"
         data-taboola-url="https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f"
         data-elvs-id=""
         data-elvs-stream-url=""
         data-is-elvs-disabled="true"
         data-tealium-id-comscore="1"data-tealium-id-datasphere="449"data-tealium-id-dealboss="516"data-tealium-id-googleanalytics="465"data-tealium-id-oneplusx="567"data-tealium-id-simplifi="560"data-tealium-id-taboola="518"data-tealium-id-truanthem="442"data-tealium-id-visto="448"         >
            <div class="page__top">

    <div class="universal-ad" data-module="universal-ad">
        <div class="universal-ad__close-button">
            <img src="/assets/shared-images/icons/close-menu.svg" alt="x" width="14" height="14" />
        </div>
        <div class="universal-ad__ad">
        <div data-module="ad" class="ad ad_position_article_universal ad_background_true"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_universal/news/local"
         data-sizes="[[1140,250],[970,250],[728,90],[1,1]]"
         data-delay="0"
         data-position="article_universal"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
    </div>
            </div>
            <div class="page__header">
<header data-module="header" class="header"
        data-alerts="true"
        data-facebook-app-id="194226194463682"
        data-twitter-id="KREM2">
    <a class="header__skip" href="#main" tabindex="1">Skip Navigation</a>
    <div class="header__main">
        <ul class="header__social-list">
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_facebook" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="facebook">Share on Facebook</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_twitter" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="twitter">Share on Twitter</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_sms" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="sms">Share on SMS</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_email" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="email">Share on Email</a>
            </li>
        </ul>
        <div class="header__main-inner">
            <div class="header__hamburger">
                <div class="header__hamburger-icon-container">
                    <div class="header__hamburger-icon"></div>
                </div>
            </div>
            <a class="header__station-branding" href="/" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="masthead-logo">
                <img class="header__logo" alt="Home" src="/assets/shared-images/logos/krem.png" loading="eager" width="112" onload="this.parentElement.style.opacity='1';" />
            </a>
            <nav class="header__not-logo">
                <h2 class="header__nav-heading">Navigation</h2>
                <div class="header__tooltip-overlay"></div>
                <ul class="header__nav">
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/news" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="News">
                                        <span class="header__nav-label">News</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/local" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Local">
                                                                    <span class="header__subnav-label">Local</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/section/inland-northbest" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Inland NorthBest">
                                                                    <span class="header__subnav-label">Inland NorthBest</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/politics" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Politics">
                                                                    <span class="header__subnav-label">Politics</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/investigative" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Investigative">
                                                                    <span class="header__subnav-label">Investigative</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/nation-world" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Nation World">
                                                                    <span class="header__subnav-label">Nation World</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/sports" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Sports">
                                                                    <span class="header__subnav-label">Sports</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/money" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Money">
                                                                    <span class="header__subnav-label">Money</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/entertainment" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Entertainment">
                                                                    <span class="header__subnav-label">Entertainment</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/health" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Health">
                                                                    <span class="header__subnav-label">Health</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/community" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="KREM Cares">
                                                                    <span class="header__subnav-label">KREM Cares</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/prize-center" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Contests">
                                                                    <span class="header__subnav-label">Contests</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/news/world/ukrainian-wsu-athlete-worries-familys-safety/293-ec89dc8c-cee2-434a-8f4f-9ab7f6b14dfc" aria-label="Read Ukrainian WSU athlete worries for family&#x27;s safety" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Ukrainian WSU athlete worries for family&#x27;s safety">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Ukrainian WSU athlete worries for family's safety" width="" height="" src="https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Ukrainian WSU athlete worries for family's safety" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_360x203.jpg" data-srcset="https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_16x9.jpg 16w, https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_140x79.jpg 140w, https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_360x203.jpg 360w, https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_540x304.jpg 540w, https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_750x422.jpg 750w, https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_1140x641.jpg 1140w, https://media.krem.com/assets/KREM/images/c38ac23d-6d7d-4afc-b718-6b86b53b91a8/c38ac23d-6d7d-4afc-b718-6b86b53b91a8_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/world/ukrainian-wsu-athlete-worries-familys-safety/293-ec89dc8c-cee2-434a-8f4f-9ab7f6b14dfc" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Ukrainian WSU athlete worries for family&#x27;s safety">Ukrainian WSU athlete worries for family&#x27;s safety</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/news/education/colville-superintendent-resigns-following-district-decision-reverse-mandate/293-d6f6c9b5-a582-4bff-89f9-166581d1afc3" aria-label="Read Superintendent Steve Fisk resigns from Colville School District" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Superintendent Steve Fisk resigns from Colville School District">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Superintendent Steve Fisk resigns from Colville School District" width="" height="" src="https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Superintendent Steve Fisk resigns from Colville School District" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_360x203.jpg" data-srcset="https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_16x9.jpg 16w, https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_140x79.jpg 140w, https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_360x203.jpg 360w, https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_540x304.jpg 540w, https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_750x422.jpg 750w, https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_1140x641.jpg 1140w, https://media.krem.com/assets/KREM/images/9bfa816b-fef7-4835-a718-29a4a88901d1/9bfa816b-fef7-4835-a718-29a4a88901d1_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/education/colville-superintendent-resigns-following-district-decision-reverse-mandate/293-d6f6c9b5-a582-4bff-89f9-166581d1afc3" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Superintendent Steve Fisk resigns from Colville School District">Superintendent Steve Fisk resigns from Colville School District</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/weather/" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather">
                                        <span class="header__nav-label">Weather</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/forecast" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Forecast">
                                                                    <span class="header__subnav-label">Forecast</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/radar" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Radar">
                                                                    <span class="header__subnav-label">Radar</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/10-day" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="10-Day">
                                                                    <span class="header__subnav-label">10-Day</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/hourly" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Hourly">
                                                                    <span class="header__subnav-label">Hourly</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/weather-maps" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Maps">
                                                                    <span class="header__subnav-label">Maps</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/closings" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Closings &amp; Delays">
                                                                    <span class="header__subnav-label">Closings &amp; Delays</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/traffic" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Traffic">
                                                                    <span class="header__subnav-label">Traffic</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/live-cameras" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather Cameras">
                                                                    <span class="header__subnav-label">Weather Cameras</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/ski-reports" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Ski Reports">
                                                                    <span class="header__subnav-label">Ski Reports</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Weather Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/weather/krem-2-weather-forecast/293-a0f43ff2-aa37-4afc-bcfc-b661849f38c1" aria-label="Read Rain and snow return Sunday" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Rain and snow return Sunday">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Rain and snow return Sunday" width="" height="" src="https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Rain and snow return Sunday" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_360x203.jpg" data-srcset="https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_16x9.jpg 16w, https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_140x79.jpg 140w, https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_360x203.jpg 360w, https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_540x304.jpg 540w, https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_750x422.jpg 750w, https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_1140x641.jpg 1140w, https://media.krem.com/assets/KREM/images/679f89d4-d4dd-4907-9c9c-a59282215bdc/679f89d4-d4dd-4907-9c9c-a59282215bdc_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/weather/krem-2-weather-forecast/293-a0f43ff2-aa37-4afc-bcfc-b661849f38c1" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Rain and snow return Sunday">Rain and snow return Sunday</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/video/weather/weather/293-e98e3bba-0498-4a68-9349-089b380e9d0d" aria-label="Read Weather Update 11pm February 26, 2022" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Weather Update 11pm February 26, 2022">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Weather Update 11pm February 26, 2022" width="" height="" src="https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Weather Update 11pm February 26, 2022" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_360x203.jpg" data-srcset="https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_16x9.jpg 16w, https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_140x79.jpg 140w, https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_360x203.jpg 360w, https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_540x304.jpg 540w, https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_750x422.jpg 750w, https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_1140x641.jpg 1140w, https://media.krem.com/assets/KREM/images/474bcd7a-ac8a-476f-bf7a-5988b168a2af/474bcd7a-ac8a-476f-bf7a-5988b168a2af_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/video/weather/weather/293-e98e3bba-0498-4a68-9349-089b380e9d0d" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Weather Update 11pm February 26, 2022">Weather Update 11pm February 26, 2022</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/near-me" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Near Me">
                                        <span class="header__nav-label">Near Me</span>
                            </a>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/verify" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="VERIFY">
                                        <span class="header__nav-label">VERIFY</span>
                            </a>
                        </li>
                        <li>
                            <div class="header__mini-live-video">
<div data-module="watch-live" class="watch-live watch-live_active_false" data-watch-enabled="true">
    <a class="watch-live__cta" href="/watch">
        <span class="watch-live__label">Watch</span>
    </a>
    <div class="watch-live__mini-live-video watch-live__mini-live-video_active_false">
        <a class="watch-live__video-link" href="/watch">
    <div data-module="mini-live-video" class="mini-live-video mini-live-video_state_stopped" data-is-watch="false">    
        <div class="mini-live-video__player"></div>
    </div>        </a>
    </div>
</div>                            </div>
                        </li>
                    <li class="header__nav-search header__nav-search_type_search">
                        <a class="header__nav-link header__nav-link_type_search" href="/search">
                            <label class="header__nav-label header__nav-label_type_search" for="site_search">Search</label>
                        </a>
                        <div class="header__subnav header__subnav_type_search">
                            <div class="header__subnav-group header__subnav-group_name_search">
                                <form class="header__search-form" method="GET" action="/search">
                                    <label class="header__search-label" for="site_search">Search:</label>
                                    <input class="header__search-box" placeholder="Search krem.com" id="site_search" type="search" name="q" />
                                    <button class="header__search-submit" type="submit">Search</button>
                                </form>
                            </div>
                            <button class="header__close-button" aria-label="close"></button>
                        </div>
                    </li>
                </ul>
                    <div class="header__sponsor">
        <div data-module="ad" class="ad ad_position_masthead_sponsor ad_background_false"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/masthead_sponsor/news/local"
         data-sizes="[[112,38]]"
         data-delay="0"
         data-position="masthead_sponsor"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_false" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                    </div>
                <a class="header__weather-link" href="/weather" data-tracking-action="weather-summary/weatherClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f">
                    <div class="header__weather">
                        <div class="header__weather-desktop-info">
                            <div class="header__weather-label header__weather-label_alerts_true">Right Now</div>
                            <div class="header__weather-city header__weather-city_alerts_true">Spokane, WA&nbsp;&raquo;</div>
                        </div>
                        <div class="header__weather-content">
                            <div class="header__weather-info header__weather-info_alerts_true">
                                <div class="header__weather-temp header__weather-temp_alerts_true">33&deg;</div>

                                <div class="header__weather-icon header__weather-icon_alerts_true">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-67_8x8.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/backgrounds/blank.png" data-src="/assets/shared-images/weather-icons/wx-67_32x32.png" data-srcset="/assets/shared-images/weather-icons/wx-67_8x8.png 8w, /assets/shared-images/weather-icons/wx-67_16x16.png 16w, /assets/shared-images/weather-icons/wx-67_32x32.png 32w, /assets/shared-images/weather-icons/wx-67_64x64.png 64w, /assets/shared-images/weather-icons/wx-67_128x128.png 128w, /assets/shared-images/weather-icons/wx-67_210x210.png 210w" sizes="26px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-67_32x32.png" srcset="/assets/shared-images/weather-icons/wx-67_8x8.png 8w, /assets/shared-images/weather-icons/wx-67_16x16.png 16w, /assets/shared-images/weather-icons/wx-67_32x32.png 32w, /assets/shared-images/weather-icons/wx-67_64x64.png 64w, /assets/shared-images/weather-icons/wx-67_128x128.png 128w, /assets/shared-images/weather-icons/wx-67_210x210.png 210w" sizes="26px" loading="lazy" /></noscript></div>
                                </div>
                            </div>
                            <div class="header__weather-city header__weather-city_alerts_true">Spokane, WA&nbsp;&raquo;</div>
                        </div>
                    </div>
                </a>
            <div class="header__alerts">
                    <a class="header__alert header__alert_type_weather header__alert_visible_true" href="/weather/alerts" data-tracking-action="weatheralert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f">Weather</a>
                    <a class="header__alert header__alert_type_closings header__alert_visible_false" href="/closings" data-tracking-action="closingsalert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f">Closings</a>
            </div>
            </nav>
        </div>
    </div>
    <div class="header__featured">
            <div class="header__featured-arrow header__featured-arrow_direction_previous"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
            <div class="header__featured-inner">
                <ul class="header__featured-list">
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/boomtown">Boomtown</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.krem.com/section/gonzaga-bulldogs">Gonzaga</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.krem.com/article/news/local/black-history/lets-talk/lets-talk-black-history-month/293-fea5d894-085e-428f-98d2-4c85d6c87d90">Let&#x2019;s Talk</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.krem.com/article/news/investigations/krem-spokane-shock-investigation/293-7c8aecc4-7a76-4f1f-a5f9-1ef293e072bf">Spokane Shock Investigation</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.krem.com/section/tom-sherry">Thank You, Tom Sherry</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/coronavirus-covid-19">Coronavirus</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/investigative">Investigations</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/section/inland-northbest  ">Inland NorthBest</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.krem.com/community">Krem Cares</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/ski-reports">Ski Reports</a>
                        </li>
                </ul>
            </div>
            <div class="header__featured-arrow header__featured-arrow_direction_next"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
    </div>
</header>            </div>
            <div class="page__dock">
                    <div class="page__breaking-news-alerts">
    <div data-module="breaking-news-alerts" class="breaking-news-alerts breaking-news-alerts_visible_false">
        <div class="breaking-news-alerts__wrap">
            <div class="breaking-news-alerts__close"></div>
            <div class="breaking-news-alerts__label">Breaking News</div>
            <ul class="breaking-news-alerts__headline-wrap">
                <template class="breaking-news-alerts__template">
                    <li class="breaking-news-alerts__item">
                        <a class="breaking-news-alerts__link" href="#" data-tracking="breaking-news-alerts/linkClicked">
                            <span class="breaking-news-alerts__headline"></span>
                            <span class="breaking-news-alerts__read-more">Read More &raquo;</span>
                        </a>
                    </li>
                </template>
            </ul>
            <a class="breaking-news-alerts__more" href="/breaking-news" data-tracking="breaking-news-alerts/moreClicked">More (<span class="breaking-news-alerts__count"></span>) &raquo;</a>
        </div>
    </div>
                    </div>
            </div>
        <main class="page__main" id="main">
            <div class="page__grid">
                


    <div data-module="grid" class="grid grid_version_2-1">
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_right grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article" data-module-sizer="article" data-count="1">
<article class="article" data-module="article"
         data-article-id="8d5d1335-232b-4fcb-8353-c55c2983cf5f"
         data-title="Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign"
         data-seo-title="Take Back Idaho calls for Janice McGeachin to resign"
         data-abstract="Take Back Idaho said it calls for McGeachin&#x27;s resignation after it learned McGeachin spoke at the America First Political Action Conference (AFPAC)."
         data-section="news"
         data-subsection="local"
         data-topic=""
         data-subtopic=""
         data-url="www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f"
         data-gpt-network-code="32805352"
         data-categories="local,news"
         data-author="KTVB Staff"
         data-keywords="local,news"
         data-has-video="true"
         data-watson-keywords="Back Idaho,Idaho Lt. Gov. McGeachin,Take Back Idaho PAC,Take Back Idaho&#x27;s news release,America First Political Action Conference"
         data-t1-publisher="zarmstrong@tegna.com"
         data-is-cct="false"
         data-original-headline="Take Back Idaho calls for Lt. Gov. McGeachin to resign"
         data-content-score="100"
         data-tracking-tags="">
        <a class="article__category" href="/section/local" data-tracking-category="article" data-tracking-action="click" data-tracking-label="article; topic; Local">Local</a>
        <h1 class="article__headline">Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign</h1>
        <div class="article__summary">Take Back Idaho said it calls for McGeachin's resignation after it learned McGeachin spoke at the America First Political Action Conference (AFPAC).</div>
        <div class="article__lead-asset">
        <div data-module="video" class="video"
             data-stream="https://video.tegna-media.com/assets/KTVB/videos/a5cc386a-6eb1-4f04-ac95-e8bdef29145d/a5cc386a-6eb1-4f04-ac95-e8bdef29145d.m3u8"
             data-float="true"
             data-thumbnail="https://media.krem.com/assets/KTVB/images/55c4c94c-5944-404a-8f03-1cfabf1feb7b/55c4c94c-5944-404a-8f03-1cfabf1feb7b_1920x1080.jpg"
             data-title="Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign"
             data-description="Take Back Idaho said it calls for McGeachin&#x27;s resignation after it learned McGeachin spoke at the America First Political Action Conference (AFPAC)."
             data-site="277"
             data-id="a5cc386a-6eb1-4f04-ac95-e8bdef29145d"
             data-mute="false"
             data-autoplay="true"
             data-link="https://www.krem.com/video/news/local/capitol-watch/take-back-idaho-calls-for-idaho-lt-gov-mcgeachin-to-resign/277-a5cc386a-6eb1-4f04-ac95-e8bdef29145d"
             data-origin="clipping"
             data-section="news"
             data-subsection="local"
             data-subcategory="local"
             data-topic="capitol-watch"
             data-subtopic=""
             data-categories="capitol-watch,news,local"
             data-captions="https://video.tegna-media.com/assets/KTVB/videos/a5cc386a-6eb1-4f04-ac95-e8bdef29145d/a5cc386a-6eb1-4f04-ac95-e8bdef29145d_vtt.vtt"
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="VOD"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration="59"
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="false"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="194226194463682"
             data-sharing-twitter-title="Take%20Back%20Idaho%20calls%20for%20Idaho%20Lt.%20Gov.%20McGeachin%20to%20resign"
             data-sharing-twitter-username="KREM2"
             data-a9-pubid="3276">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign",
                    "description": "Take Back Idaho said it calls for McGeachin&#x27;s resignation after it learned McGeachin spoke at the America First Political Action Conference (AFPAC).",
                    "thumbnailUrl": "https://media.krem.com/assets/KTVB/images/55c4c94c-5944-404a-8f03-1cfabf1feb7b/55c4c94c-5944-404a-8f03-1cfabf1feb7b_1920x1080.jpg",
                    "uploadDate": "2/26/2022 4:38:35 PM",
                    "duration": "59",
                    "contentUrl": "https://www.krem.com/video/news/local/capitol-watch/take-back-idaho-calls-for-idaho-lt-gov-mcgeachin-to-resign/277-a5cc386a-6eb1-4f04-ac95-e8bdef29145d",
                    "embedUrl": "https://media.krem.com/embeds/video/277-a5cc386a-6eb1-4f04-ac95-e8bdef29145d/iframe"
                    }
                        </script>
                </div>
        </div>
        <aside class="article__meta">
                <div class="article__author">
                    <span class="article__meta-label">Author:</span> KTVB Staff
                </div>
                <div class="article__published">
                    <span class="article__meta-label">Published:</span> 1:25 PM PST February 26, 2022
                </div>
                <div class="article__updated">
                    <span class="article__meta-label">Updated:</span> 6:16 PM PST February 26, 2022
                </div>
    <div data-module="article-sharing" class="article-sharing">
        <a class="article-sharing__icon" href="https://www.facebook.com/dialog/share?app_id=194226194463682&display=popup&href=https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f&redirect_uri=https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f" target="_blank" data-tracking-action="sharing/facebookLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f">
            <img class="article-sharing__logo" alt="Facebook" src="/assets/shared-images/icons/facebook.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
        <a class="article-sharing__icon" href="https://twitter.com/intent/tweet?text=Take%20Back%20Idaho%20calls%20for%20Idaho%20Lt.%20Gov.%20McGeachin%20to%20resign&url=https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f&via=KREM2" target="_blank" data-tracking-action="sharing/twitterLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f">
            <img class="article-sharing__logo" alt="Twitter" src="/assets/shared-images/icons/twitter.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
    </div>        </aside>
    <div class="article__body">
                    <div class="article__section article__section_type_text utility__text">
<p>BLACKFOOT, Idaho — A new political action committee in Idaho announced Saturday that it is calling for the resignation of Idaho Lieutenant Governor Janice McGeachin.&nbsp;</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a href="/article/news/investigations/7-investigates/take-back-idaho-pac-legislature/277-ac4ecc66-5436-42b8-b58f-8c33f987b38a" rel="noopener noreferrer" target="_blank">Take Back Idaho</a> said it calls for McGeachin's resignation after it learned McGeachin spoke at the America First Political Action Conference (AFPAC).&nbsp;</p>                    </div>
                        <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid1 ad_background_true"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_mid1/news/local"
         data-sizes="[[300,250],[1,1],[750,570],[1,2]]"
         data-delay="8"
         data-position="article_mid1"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                        </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Several Idahoans who've been involved in policy-making for decades formed the Take Back Idaho PAC late last year.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>A few notable names among <a href="https://takebackidaho.com/about-take-back-idaho-pac/">Take Back Idaho PAC's board of directors</a> are retired Idaho Supreme Court Justice and former Idaho Attorney General Jim Jones, former Speaker of the House Bruce Newcomb and former Senate Pro Tempore Bob Geddes, all registered Republicans. Past President of the Idaho Cattle Association Jennifer Ellis chairs the board of directors.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>According to Take Back Idaho's news release, AFPAC is a "far-right, white nationalist alternative," to the Conservative Political Action Conference (CPAC). CPAC is currently taking place in Orlando, Florida and the conference runs through Sunday.&nbsp;</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>CPAC began in 1974 and brings together elected officials and conservative leaders from around the world. The 2022 event is headlined by speakers such as former U.S. President Donald Trump, Donald Trump Jr., Sen. Ted Cruz and more.&nbsp;</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>AFPAC’s listed attendees and speakers included a roster of "white nationalist figures," including its founder Nick Fuentes, Gavin McInnes, Vincent James, <a href="%7C20e07cdd9c6048f0c34b08d9f95d6008%7Cccd8a79b7268413b878971f8b6f4c0df%7C1%7C0%7C637815001725345831%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0=%7C2000&sdata=bSpzeC8y+noQJIZd1l5V7A9DJoWDov%2Fadah3IHX75nQ=&reserved=0">Milo Yiannopoulos</a>, Baked Alaska and Beardson Beardsly, Take Back Idaho said.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Take Back Idaho's news release said Fuentes gave a speech at AFPAC Friday night where he said, "the US government has become the Great Satan that many have called it." Fuentes also said it is a "good thing" to compare Vladimir Putin to Adolf Hitler, before later adding "I shouldn't have said that," according to Take Back Idaho.&nbsp;</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>During her speech to the in-person AFPAC crowd, McGeachin said; “Congratulations on your event. Keep up the good work fighting for our country.” Take Back Idaho said McGeachin also added, “I need freedom fighters... even when that means fighting amongst our own ranks because too many Republicans don't exhibit the courage today." The AFPAC speech was also viewed online.&nbsp;</p>                    </div>
                                <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid2 ad_background_true"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_mid2/news/local"
         data-sizes="[[300,250],[1,1]]"
         data-delay="8"
         data-position="article_mid2"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey="[&#xD;&#xA;  &quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;&#xD;&#xA;]"
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                                </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_1140x641.jpg" data-srcset="https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_16x9.jpg 16w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_140x79.jpg 140w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_360x203.jpg 360w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_540x304.jpg 540w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_750x422.jpg 750w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_1140x641.jpg 1140w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_1140x641.jpg" srcset="https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_16x9.jpg 16w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_140x79.jpg 140w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_360x203.jpg 360w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_540x304.jpg 540w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_750x422.jpg 750w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_1140x641.jpg 1140w, https://media.krem.com/assets/KTVB/images/d899c972-be2c-47ac-9669-94792b5a11e1/d899c972-be2c-47ac-9669-94792b5a11e1_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
            <div class="photo__credit">Credit: Take Back Idaho</div>
            </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Take Back Idaho has a stated goal of freeing Idaho "from the grip of the Idaho Freedom Foundation, its partner organizations, and their acolytes in the GOP legislative ranks." The organization said McGeachin is supported by many Idaho Freedom Foundation (IFF) board members and donors.&nbsp;</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Take Back Idaho issued the following statement in its announcement Saturday, calling for Idaho Lt. Gov. McGeachin to resign:</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>“McGeachin’s participation in AFPAC shows that she is openly courting the most extreme fringes of society—including QAnon conspiracy theorists, January 6 insurrectionists, white nationalists and Holocaust deniers—on a national stage. She intends to be their voice in Idaho politics. McGeachin is dangerous to Idahoans and to all of us who value the rule of law.</em></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>“The fact that McGeachin didn’t announce or mention the speech to her constituents shows she knows enough about AFPAC’s extremist leadership and followers to know Idahoans would not approve. Her secrecy, hypocrisy, and lack of moral character should now be crystal-clear to all Idahoans: She’s unfit to hold her current office, and certainly should not be one heartbeat away from the governor’s office.</em></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>“McGeachin must resign immediately.”</em></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>The Take Back Idaho news release said at one point during the AFPAC Friday, attendees chanted "Putin! Putin," and cheered the Russian invasion of Ukraine.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>In response to Take Back Idaho's announcement, McGeachin released a statement of her own Saturday afternoon on her 'Janice McGeachin for Governor' Facebook page:</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>"The media wants us to play a guilt-by-association game where conservatives (and only conservatives) are accused of believing everything ever said by anyone with whom they share a stage. Don't tell me what I believe. Listen to my words.&nbsp;</em></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>"I support America First policies including individual liberty, election integrity, a strong and secure border, school choice, energy independence, reducing taxes and regulations, and supporting American businesses.&nbsp;</em></p>                    </div>
                                <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid3 ad_background_true"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_mid3/news/local"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-position="article_mid3"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>"I was invited to submit a video to AFPAC, and I took the opportunity to share my views about these vital America First policies.</em></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>"I do not and have never supported identity politics or other discriminatory views that only seek to divide us and not unite us. Anyone who actually listens to what I say or who pays attention to what I've done in my many years of service knows this is true."</em></p>                    </div>
                                <div class="article__section article__section_type_embed">
                                    <iframe src='https://www.facebook.com/plugins/post.php?href=https%3A%2F%2Fwww.facebook.com%2FMcGeachinforidaho%2Fposts%2F480591610180900&width=500&show_text=true&height=738&appId' width='500' height='738' frameborder='0' style='border:0px;' ></iframe>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>RELATED:</strong> <a href="/article/news/investigations/7-investigates/take-back-idaho-pac-legislature/277-ac4ecc66-5436-42b8-b58f-8c33f987b38a">Take Back Idaho aims to loosen extremism's grip on Legislature</a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>The Take Back Idaho PAC includes conservatives as well as moderates, Jones said, and includes native Idahoans, former leaders of the Idaho House and Senate, educators, a former Secretary of State, ranchers, farmers and veteran GOP officers among its ranks.</p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_1140x641.jpg" data-srcset="https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_16x9.jpg 16w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_140x79.jpg 140w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_360x203.jpg 360w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_540x304.jpg 540w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_750x422.jpg 750w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_1140x641.jpg 1140w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_1140x641.jpg" srcset="https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_16x9.jpg 16w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_140x79.jpg 140w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_360x203.jpg 360w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_540x304.jpg 540w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_750x422.jpg 750w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_1140x641.jpg 1140w, https://media.krem.com/assets/KTVB/images/a7dc925e-1c1a-49e3-9633-952d547fc75a/a7dc925e-1c1a-49e3-9633-952d547fc75a_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
            <div class="photo__credit">Credit: Take Back Idaho</div>
            </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<h2>Watch more <a href="/politics" rel="noopener noreferrer" target="_blank">Idaho politics</a>:</h2>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>See all of our latest political coverage in our&nbsp;</strong><a href="https://www.youtube.com/embed/videoseries?list=PLggbABFJJpUCZb0l7fP0i6JDAosAWtHhX" rel="noopener noreferrer" target="_blank">YouTube playlist</a><strong>:</strong></p>                    </div>
                                <div class="article__section article__section_type_embed">
                                    <iframe src='https://www.youtube.com/embed/videoseries?list=PLggbABFJJpUCZb0l7fP0i6JDAosAWtHhX' width='100%' height='415' frameborder='0' style='border:0px;' ></iframe>
                                </div>

<div data-module="related-stories" class="related-stories">
    <h2 class="related-stories__heading">Related Articles</h2>
    <ul class="related-stories__stories">
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.krem.com/article/news/local/idaho-ukrainian-looking-to-raise-funds-to-aid-his-homeland/277-bbe722ba-b8b8-4b4b-ade9-9619b2653ae1" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="Idaho Ukrainian looking to raise funds to aid homeland">Idaho Ukrainian looking to raise funds to aid homeland</a>
            </li>
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.krem.com/article/life/parenting/how-to-talk-with-children-about-russias-invasion-of-ukraine/277-92028c46-7ee4-4b60-8ef1-eb4876f60cb1" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="How to talk with your children about Russia&#x27;s invasion of Ukraine">How to talk with your children about Russia&#x27;s invasion of Ukraine</a>
            </li>
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.krem.com/article/news/nation-world/ukraine/biden-administration-putin-sanctions/507-41aa743f-edeb-4710-9491-8b03fc92aaf9" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="White House to impose new sanctions targeting Putin himself">White House to impose new sanctions targeting Putin himself</a>
            </li>
    </ul>
</div>    </div>
    <script type="application/ld+json">
        {
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "headline": "Take Back Idaho calls for Idaho Lt. Gov. McGeachin to resign",
  "datePublished": "1:25 PM PST February 26, 2022",
  "dateModified": "6:16 PM PST February 26, 2022",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.krem.com/article/news/local/take-back-idaho-calls-for-idaho-lt-gov-janice-mcgeachins-resignation/277-8d5d1335-232b-4fcb-8353-c55c2983cf5f"
  },
  "author": {
    "@type": "Person",
    "name": "KTVB Staff"
  },
  "publisher": {
    "@type": "Organization",
    "name": "KREM",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.krem.com/assets/shared-images/amp-logos/krem.png",
      "width": 340,
      "height": 60
    }
  }
}
    </script>
</article>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_taboola" data-module-sizer="taboola" data-count="1">
    <div data-module="taboola" class="taboola" id="taboola-below-article-thumbnails-2nd-::articleNumber::"
         data-page-type="article"
         data-ad="below_taboola"
         data-mode="thumbnails-h2"
         data-target-type="mix"
         data-placement="Below Article Thumbnails 2nd"
         data-url="http://www.krem.com::contentUrl::"
         data-id="taboola-below-article-thumbnails-2nd-::articleNumber::">
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

                    <div class="grid__sticky-column grid__sticky-column_side_right">
                        <div class="grid__sticky-content" data-columns="1">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_atf ad_background_true"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_atf/news/local"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-position="article_atf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_atf/news/local&amp;sz=300x250&amp;c=623" width="300" height="250" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_related-videos" data-module-sizer="related-videos" data-count="1">
    <div data-module="related-videos" class="related-videos">
        <div class="related-videos__player">
        <div data-module="video" class="video"
             data-stream="https://video.tegna-media.com/assets/KREM/videos/ffa7fd86-4ce0-4486-9e10-99cb9f25d7f3/ffa7fd86-4ce0-4486-9e10-99cb9f25d7f3.m3u8"
             data-float="false"
             data-thumbnail="https://media.krem.com/assets/KREM/images/28ab4cb9-9763-49d4-bb2f-4256ea994810/28ab4cb9-9763-49d4-bb2f-4256ea994810_1920x1080.jpg"
             data-title="Northern Quest Sports Desk: Feb. 25, 2022"
             data-description="KREM 2&#x27;s Travis Green recaps tonight&#x27;s High School basketball match ups in the Inland Northwest."
             data-site="293"
             data-id="ffa7fd86-4ce0-4486-9e10-99cb9f25d7f3"
             data-mute="true"
             data-autoplay="true"
             data-link="https://www.krem.com/video/sports/high-school/hs-basketball/northern-quest-sports-desk-feb-25-2022/293-ffa7fd86-4ce0-4486-9e10-99cb9f25d7f3"
             data-origin="video"
             data-section="sports"
             data-subsection="high-school"
             data-subcategory="high-school"
             data-topic="hs-basketball"
             data-subtopic=""
             data-categories="hs-basketball,sports,local,news,high-school"
             data-captions=""
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="VOD"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration=""
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="false"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="194226194463682"
             data-sharing-twitter-title="Northern%20Quest%20Sports%20Desk:%20Feb.%2025,%202022"
             data-sharing-twitter-username="KREM2"
             data-a9-pubid="3276">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "Northern Quest Sports Desk: Feb. 25, 2022",
                    "description": "KREM 2&#x27;s Travis Green recaps tonight&#x27;s High School basketball match ups in the Inland Northwest.",
                    "thumbnailUrl": "https://media.krem.com/assets/KREM/images/28ab4cb9-9763-49d4-bb2f-4256ea994810/28ab4cb9-9763-49d4-bb2f-4256ea994810_1920x1080.jpg",
                    "uploadDate": "11:35 PM PST February 25, 2022",
                    "duration": "",
                    "contentUrl": "https://www.krem.com/video/sports/high-school/hs-basketball/northern-quest-sports-desk-feb-25-2022/293-ffa7fd86-4ce0-4486-9e10-99cb9f25d7f3",
                    "embedUrl": "https://media.krem.com/embeds/video/293-ffa7fd86-4ce0-4486-9e10-99cb9f25d7f3/iframe"
                    }
                        </script>
                </div>
        </div>
        <p class="related-videos__topic">In Other News</p>
        <h4 class="related-videos__title">Northern Quest Sports Desk: Feb. 25, 2022</h4>
    </div>
                                    </div>
                                </div>
                        </div>
                    </div>
            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_flex_btf ad_background_true"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_flex_btf/news/local"
         data-sizes="[[970,250],[728,90],[1140,286],[1,1]]"
         data-delay="8"
         data-position="article_flex_btf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/wa-spokane-KREM-B3354_DesktopTablet/article_flex_btf/news/local&amp;sz=970x250|728x90|1140x286|1x1&amp;c=624" width="1140" height="286" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article-loader" data-module-sizer="article-loader" data-count="1">

<div class="article-loader" data-module="article-loader">
    <button class="article-loader__button"></button>
</div>                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
    </div>

            </div>
        </main>
            <div class="page__footer page__footer_theme_default">
<footer data-module="footer" class="footer">
    <div class="footer__outer">
        <div class="footer__inner">
            <div class="footer__logo-wrap">
                <img class="footer__logo" alt="KREM-TV" src="/assets/shared-images/logos/krem.png">
            </div>
            <div class="footer__menu">
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://www.krem.com/kremjobs" target="_blank" rel="noopener">Jobs</a></li>
                                <li class="footer__item"><a class="footer__link" href="/terms" target="_self" rel="">Terms of Service</a></li>
                                <li class="footer__item"><a class="footer__link" href="/privacy" target="_self" rel="">Privacy Policy</a></li>
                                <li class="footer__item"><a class="footer__link" href="/adchoices" target="_self" rel="">Ad Choices</a></li>
                    </ul>
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://interactive.krem.com/pdfs/PublicFileReport.pdf" target="_blank" rel="noopener">EEO Public File Report</a></li>
                                <li class="footer__item"><a class="footer__link" href="/fcc-public-inspection-file" target="_self" rel="">FCC Online Public Inspection File</a></li>
                                <li class="footer__item"><a class="footer__link" href="/closed-captioning" target="_self" rel="">Closed Caption Procedures</a></li>
                                <li class="footer__item footer__item_visible_false"><a class="footer__link footer__link_behavior_show-consent-options" target="_self" href="/do-not-sell-my-information">Do Not Sell My Information</a></li>
                    </ul>
            </div>
            <div class="footer__copyright">
                &copy; 2022 KREM-TV. All Rights Reserved.
            </div>
        </div>
    </div>
</footer>            </div>
    </div>
        <div class="page__interstitial">
        <div data-module="ad" class="ad ad_position_exit_interstitial ad_background_true"
         data-status="new"
         data-path="/32805352/wa-spokane-KREM-B3354_DesktopTablet/exit_interstitial/news/local"
         data-sizes="[[1,1]]"
         data-delay="8"
         data-position="exit_interstitial"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
        <div class="page__notifications">

<div data-module="notifications" class="notifications" style="display:none">
    <div class="notifications__logo-container">
        <img class="notifications__logo" alt="KREM" src="/assets/shared-images/logos/krem.png" />
    </div>
    <h2 class="notifications__heading">KREM would like to send you push notifications about the latest news and weather.</h2>
    <p class="notifications__description">Notifications can be turned off anytime in the browser settings.</p>
    <div class="notifications__buttons">
        <button class="notifications__button notifications__button_option_no notifications__button_default_false">No Thanks</button>
        <button class="notifications__button notifications__button_option_yes notifications__button_default_true">Allow</button>
    </div>
</div>
        </div>
        <div class="page__toasts">

<div class="toasts">
    <script class="toasts__toast-template" type="text/template">
        <div class="toasts__toast toasts__toast_new_true">
            <div class="toasts__logo-container">
                <img class="toasts__logo" src="/assets/shared-images/logos/krem.png" />
            </div>
            <div class="toasts__close">×</div>
            <div class="toasts__content">
                <div class="toasts__title"></div>
                <div class="toasts__body"></div>
                <p class="toasts__link">Read More</p>
            </div>
        </div>
    </script>
</div>        </div>
<div class="modal modal_open_false" data-theme="modal">
    <button class="modal__close-button" aria-label="close"></button>
    <div class="modal__content"></div>
</div>    <script src="https://amp.akamaized.net/hosted/1.1/player.esi?apikey=tegna&version=9.1.5"></script>
    <script>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</script>
    <script data-base="/" data-modules="accessibility-statement,ad,adchoices,all-alerts,app-badge,app-promo-link,article,article-loader,article-sharing,article-verify-claim,article-verify-follow-subscribe,breaking-news-alerts,breaking-news-list,carousel,chapter-slider,closings,countdown,datasphere,datasphere-ad-article,datasphere-ad-front,election-single-race,elections,error,footer,from-you,gallery,grid,header,headline-list,hot-races,hot-races-carousel,hourly-graph,iframe,lazy-image,live-broadcasts,live-video-banner,longform,mini-live-video,modal,nbc-olympics-live-streams,nbc-olympics-medals-count,nbc-olympics-tv-schedule,newsletter-signup,notifications,olympics-medal-count,page,personal-info,photo,pollen,privacy,radar-gallery,raw-html,related-stories,related-videos,right-now-hourly,right-now-radar,search,story,story-list,story-row,taboola,toasts,tos,ugc-cta,universal-ad,video,watch-carousel,watch-live,watch-secondary-content,weather-10-day,weather-alerts-list,weather-front-link,weather-hourly,weather-interactive-radar,weather-maps,weather-nav" data-version="6.2.1">!function(){if(window.tegna.supportsJavascript){var e=document.currentScript.dataset.modules.split(","),s=["page","photo","lazy-image","ad","gallery","video","taboola","related-stories","raw-html","elections","election-single-race"];for(var a=document.querySelectorAll("[data-module]"),t=0;t<a.length;++t)n=void 0,function(e,s){for(var a=s.length,t=0;t<a;t++)if(s[t]===e)return 1}(n=a[t].getAttribute("data-module"),s)||s.push(n);var r=document.currentScript.dataset.version,i=document.currentScript.dataset.base,l=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.tealiumUrl:"";const o={utils:"tegna-utils_"+r,bem:"bem_"+r,"jquery-utils":"jquery-utils_"+r,storage:"tegna-storage_"+r,common:"common.min_"+r,swiper:"assets/js-libs/swiper/swiper.min","live-messages":"assets/js-libs/live-messages/live-messages",luxon:"assets/js-libs/luxon/luxon.min",tealium:l,signalr:"assets/js-libs/signalr/signalr.min",hls:"https://amp.akamaized.net/players/9.0.13+premier/akamai/amp/core/libs/hls.min",comscore:"assets/js-libs/comscore/comscore.min",places:"//maps.googleapis.com/maps/api/js?key=AIzaSyBEGr3U4E-OGcjwkhiXfqxfuvOqDQ7Z96c&libraries=places","@firebase/app":"firebase-app","@firebase/messaging":"firebase-messaging"};e.forEach(e=>{e in o==!1&&(o[e]=`${e}_${r}`)}),require.config({baseUrl:i,waitSeconds:30,bundles:{common:["page","universal-ad","header","footer","grid","breaking-news-alerts","tegna-utils","tegna-storage","tegna-tracking","header-updater"]},paths:o,shim:{swiper:{exports:"Swiper"},signalr:{exports:"signalR"},tealium:["jquery"]}}),s.forEach(s=>{try{require([s])}catch(e){void 0}})}var n}();
//# sourceMappingURL=configure-require.js.map</script>
        <script data-api-key="AIzaSyD4bH1X6ceGEGr4pKx-lbUmOz-OK5CUUmg" data-project-id="krem-news-app" data-sender-id="766556992382" data-app-id="1:766556992382:web:0d9d6eb8182b9b91">!function(){var e,a,i,p,t;window.tegna.supportsJavascript&&(e=document.currentScript.dataset,a=e.apiKey,i=e.projectId,p=e.senderId,t=e.appid,require(["@firebase/app","@firebase/messaging"],function(e){e.initializeApp({apiKey:a,authDomain:`${i}.firebaseapp.com`,databaseURL:`https://${i}.firebaseio.com`,projectId:i,storageBucket:`${i}.appspot.com`,messagingSenderId:p,appId:t}),window.firebase=e}))}();
//# sourceMappingURL=firebase.js.map</script>
    <script>!function(){function e(){void 0;for(var e,t=document.getElementsByTagName("noscript"),n=0;n<t.length;n++){var o=t.item(n);o.outerHTML=(e=o.innerHTML,o=void 0,(o=document.createElement("textarea")).innerHTML=e,0===o.childNodes.length?"":o.childNodes[0].nodeValue)}}var t,n,o;window.tegna.supportsJavascript||(t=document.body,(n=document.createElement("div")).innerHTML='<div style="background-color:#c50000;font-family:sans-serif;color:#ffffff;text-align:center;"><h2 style="margin:0;padding:10px 0;">Your browser is not fully supported.</h2><p style="margin:0;padding: 10px 0;">For full feature support, please upgrade to a modern browser such as <a href="https://www.microsoft.com/en-us/edge" style="color:#ffffff;" target="_blank">Microsoft Edge</a>.</p></div>',t.insertBefore(n,t.firstChild),e(),o=window.setInterval(function(){document.getElementsByTagName("noscript").length?e():clearInterval(o)},500))}();
//# sourceMappingURL=old-browser.js.map</script>
    <script>tegna.performance.parsed = { time: performance.now() };</script>
    <script>window.performance.mark('tegna_dom_parsed');</script>
    <script>window.tegna = window.tegna || {}; window.tegna.loaded = true;</script>
</body>
</html>
